OSX下的Python多版本管理器pyenv的安装设置

以OS X目前最新版本OS X EI Capitan 10.11.4为例。

1. 安装brew

我们可以用brew命令来更新OSX系统,brew命令类似于RHEL的yum和ubuntu的apt-get命令。
OSX没有自带brew,登陆Homebrew网站,找到ruby代码来安装brew

  • 如果想升级新的homebrew,可以用命令brew update
  • 如果想安装软件包,可以用命令brew install XXXXX,XXXX是软件包的名称
  • 如果想更新软件包,可以用brew upgrade [XXXX],XXXX是软件包的名字,如果省略不写,就是更新所有可更新的软件包。

2. 安装pyenv

安装好brew后,就可以用brew来安装pyenv的最新版本了,而且会自动下载依赖包:

按照安装完后Caveats的提示要添加两条环境变量到~/.bash_profile文件里(如果没有需要新建):

需要使环境变量生效
运行命令. ~/.bash_profile或者source ~/.bash_profile

3.安装zlib依赖

将zlib的头文件及库文件添加至系统默认的路径:

4. pyenv使用指南

  1. pyenv versions查看系统的上安装的Python版本。 其中前面的*表示当前工作目录正在使用的版本,其中 的 system表示系统自带的 Python 版本:
  2. pyenv install 安装其他版本的Python。例如安装3.5.1和3.4.4版本:
  3. pyenv local 切换python版本。
    示例: 

其他版本的工作目录创建方法类似(如果是用系统自带版本,用pyenv local system即可使当前工作目录使用系统自带的Python2.7.10)

1 1 收藏 评论

相关文章

可能感兴趣的话题



直接登录
跳到底部
返回顶部